Description
How does Evolve consider the following points for the field "Due Status"?
How "Due Status" parameter is counted?
Where the data come from?
Are the weekends and holidays included? If yes, for which country?
Applies To
Evolve, all versions
Cause
Details required on how the Due Status parameter is calculated on Evolve.
Solution
How "Due Date" parameter is counted?
For Standard Workflow (i.e. One Step , Two Step), the default due date is 1 day. If you would like to change the default due date for a task, use the configuration key titled StandardWorkflowTaskDueDays.
For Form and Excel Workflow these dates are calculated from properties “Duration” and “DurationUnit” of Activity/Approval node or workflow.
Where the data come from?
Due date is calculated with the help of properties "Duration" and "Duration Unit". These properties can be set for both individual Activity node/Approval node or workflow process. For more information related to the properties, kindly refer to the following document =>https://docs.winshuttle.com/evolve-en-20-2-online-help/solution-developer-help/workflow-nodes/Activitynodeproperties.htm
How working days & hours being determined?
There is no concept of working hours, we consider 24 hours to be a day. Working days are determined with the value of "BusinessCalendar" key. If its value is set to true, then weekends are considered.
Are the weekends and holidays included? If yes, for which country?
By default, weekends are included. In case there is a need to include/exclude weekends or holiday in calculation, then use the configuration key titled BusinessCalendar and Holiday key. For more information about how these keys work, kindly refer to the following document =>https://docs.winshuttle.com/studio-manager-en-20-2-online-help/options-table.htm
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