Description
SAML Azure AD: In case if any user is having the username and email id values different, then they will need to update the claims in Evolve database manually.
Applies To
Evolve
Cause
- Evolve setup is of SAML Azure AD.
- Any user having a username as test@abc.com but email id as test@def.com
- Login for this user won't work.
Solution/Immediate Workaround
Following query needs to be executed on Evolve database and then perform an Application pool recycle for the Evolve or application or perform an IIS reset on Evolve server.
update [dbo].[IdentityConfiguration]
set Value ='<claims>'
where [Key] = 'SamlEmailAddressPath'Claims that customer needs to use for its login. By default we are using emailaddress claims in our application and its default value value is "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/emailaddress".
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