Description
User is able to submit the script without any issues but when It is executed on server it is throwing error "Data file Could not be saved". The issue is faced by only one user and no other user can see this issue
1. Whether data got uploaded to SAP, after error is reported on Job status page ? No, the journal was not posted to SAP. The workflow terminated with error.
2. Is user experiencing same error with all jobs or is it with specific jobs with specific excel workbook ? They have tried different templates (workbooks) within the same workflow solution, all with the same result.
3. Same issue when downloading a fresh template from Site and then try submitting ? Yes
Applies To
Foundation 12.1.X
Cause
As per analysis after going through the worker logs, it was observed that user submitting template having locale "en-BB" was creating issue in autorun.
Immediate Workaround
Change locale to "en-US" and then re-submit template
Re-installing Excel can also resolve that error message
Additional Information
If additional assistance is require, please share the following with Winshuttle Support:
1. Enable Worker logs to "All" for all categories mentioned and then run the use case. Once logs are generated with detailed logs, share with us. Worker logs can be turned off after log generation.
How to generate Server Worker and Manager Logs
2. Share the Excel template used in processing the script. In case excel has confidential data, please remove the data only and no other attributes of excel workbook e.g. Protection level.
Note that there is an existing improvement request (WIN-40701) for that to be potentially considered in future releases
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