Description
How to enable LMS logs.
Applies To
Foundation 11.x and 12.x
Cause
You want to analyse LMS logs to review licensing errors or other specific errors with the licensing server.
Solution/Immediate Workaround
On your LMS Server (Licensing Server) we will have to edit the web.config files in the below paths please be aware that the Drive might be different depending on where you installed the product.
C:\Program Files\Winshuttle\LMS\Services
C:\Program Files\Winshuttle\LMS\Services\bin
Open each of the web.config files in the location above and search for the below tag:
<root>
<level value="ERROR" />
<priority value="ERROR" />
<appender-ref ref="rollingFile" />
</root>
Change to :
<root>
<level value="Debug" />
<priority value="Debug" />
<appender-ref ref="rollingFile" />
</root>
See below after the changes have been applied to both web.config files perform a IIS reset.
To perform an IIS reset open the windows command line as administrator by typing cmd then
'Run as administrator'
When you see this screen the IIS reset was successful.
You now can go to your logging folder and verify if you can see the logs as per below:
The logging folder is per design on below location but can be different as in Drive according to where the product was installed.
C:\Program Files\Winshuttle\LMS\Site\Logs
Also if collecting logs make sure to write down the exact time and day when you reproduced the error as this will help Winshuttle support to pin point the exact error in the logs.
Additional Information
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