Description
Email approval is not working. Customer clicks on approve but the task still shows as assigned in the task list instead of completed.
Applies To
Foundation 11.x and 12.x
Cause
Incorrect email server settings and mail protocols used.
Solution
Please be aware before you even attempt to get your email approval working make sure you are testing out your settings you received from your Office 365 Exchange Admin.
You can test those settings via the Microsoft URL below
https://testconnectivity.microsoft.com/
Enter your email details and characters and proceed to Perform Test:
This will let you know if the test was successful or not.
If your test was not successful you should contact your Local IT or who ever is in charge of the mail exchange server.
Steps Taken:-
1. While analyzing the svservice logs, it was found that the gmail server was being blocked by the firewall.
2. Customer contacted their IT team and gathered their internal imap server settings.
3. We changed the email approval server to their internal imap server and configured all the respective admin keys. After that email approval functionality worked fine
Attention:
Not all email protocols (e.g IMAP, POP3 SMTP etc.) are supported with every Mail server.
Always contact your IT department to get the right mail server port details and supported mail protocols.
Always verify that the email approval has been setup correctly as per below:
Should you still encounter issues go ahead and configure the workflow logs and reproduce the issue and contact winshuttle support for further analysis.
How to enable the workflow logs:
Additional Information
https://support.winshuttle.com/hc/en-us/articles/360023442872-Email-Approval-Configuration-Keys
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