Description
When creating a script in transaction Code BP, I am unable to select the Business Partner from the Search list.
Applies to
Non-Batch and Batch Mode recordings in Studio and Transaction.
Cause
The ALV Grid information is not captured in the script and it is unable to proceed to change the Business Partner.
Solution
Use the Open BP function to go directly to the specified Business Partner.
This will allow you to go directly to the next screen without having to select from the Search results ALV grid.
Additional Information
After selecting the Role, you'll need to click the Display / Change to make any edits.
The portion of the script that is recorded to change modes needs to be placed within an If First Transaction condition to avoid switching back and forth between Display and Change for subsequent records.
If the change of role trigger a change of screen layout (additional tab for instance), then at the end of creating the script you need to change the BP role back to 0000 General Data.
You then need to copy this section to the top of the script just below the Business Partner number.
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