Description
Error message "The request failed with HTTP status 401: Unauthorized" is received with reading data from forms., user tried reading data separately with the read transaction from the form solution and it returns data without any problem.
Applies to
Central
10.X
Cause
Possible causes are as follows:
- The user has not been granted the proper roles and permissions in SharePoint.
- The user has changed their domain password.
- The user's logon credentials for Windows are not the same as those for SharePoint.
- Kerberos configuration set up might be gone wrong
Solution
Possible solutions are as follows:
- Add the user to the Members Group or grant them Contribute rights in SharePoint for the Winshuttle Central site.
- Confirm that the user's domain password has not changed.
- Confirm your Windows/SharePoint credentials.
If you need to log in to your Winshuttle Central site with new credentials, see How to log onto your Winshuttle Central site with new credentials
Follow the Kerberos setup for the Winshuttle Server and workflow server which will resolve this error
The setup is as follows:
Type | SAP Integration Server | Workflow Server |
Windows Authentication | Enable | Enable |
Anonymous Authentication | Enable | Enable |
ASP.NET Impersonation | Disable | Enable |
Kernel Mode Authentication | Off | Off |
Providers | Negotiate Only | Negotiate NTLM |
4) check whether below keys are set in
in registry keys on server in all the Web front ends;
- DisableStrictNameChecking
- BackConnectionHostNames ,
- DisableLoopBack
5) Check Composer/Foundation Ports for user on their machines by customer IT.
6) If all above changes are in place Get the Foundation logs
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