Description
We get the following error when we select any SAP server from Winshuttle specific SAP logon pad
Applies to
Transaction
10.X, 11.X
Cause
If you receive this SAP Logon error when you try to connect to SAP through Winshuttle Transaction, there might be a discrepancy between saplogon.ini files on your system. Because of Windows security settings in Windows Vista/Windows 7, the .ini file cannot be modified in the Windows directory. Instead, a separate copy of the ini file is created when you try to save changes. Transaction will not look at that new .ini file unless you have specified the new location in the Tools > Options .
This error can also be caused by a missing entry in your services file
Solution
There are two options for correcting the discrepancy with the saplogon.ini files:
- Turn off User Account Control (UAC) in Windows so that changes can be made to the original saplogon.ini file.
- If UAC cannot be turned off, you will need to set an environmental variable SAPLOGON_INI_FILE and point to the file that can be modified by the user. See the attached SAP note for details.
If the problem is not resolved by using the above methods, you will need to make changes to your services file. This can typically be found at C:\Windows\System32\drivers\etc\services, and the steps to take can be found in the attached Services file change document.
This error can also occur for GUI scripts if the software bit version is misaligned (please double check your bit version against your Excel version).
Additional Information
We can get the path of saplogon.ini file from SAP GUI logon pad.
Open SAP logon pad >> Options >> SAP Logon options >> Local Configuration files(if it is available on desktop) / Server Configuration files(if kept on shared folder or site) >> Connection
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