Description
When the customer follows the below steps, "Server was Unable to Process Request => Subquery Returned more than 1 Value" error message might occur.
Applies to
Transaction, Central v.10x
Cause
Users might have multiple login (different users) to the desktop products from one computer/laptop. Due to this, the duplicate entries are being created in SQL server database. The only option is to manually run the script to delete the duplicate entries from SQL.
Solution
With SQL Server Management Studio, navigate to the SQL instance containing the eshuttleDB. If you do not know where this is located, do the following:
In a browser navigate to the Winshuttle Central Site.
- Click on Winshuttle Central Administration.
- Click on Database Connection.
- The connection string will display the instance and database name.
- Connect to the SQL Server box
Navigate to the dbo.shuttleusers table.
Right-click on the dbo.shuttleusers and Select Top 1000 Rows.
There will be a user name in more than one entry.
Right click on the dbo.shuttleusers table and Edit Top 200 Rows.
UPDATE one of the duplicates by appending _duplicate to the end of the username value.
Alternatively, if adding duplicate doesn't work, delete the entry by executing the query "DELETE FROM dbo.ShuttleUsers WHERE uid = 999999", where 999999 is the UID that should be deleted.
User can now test the same scenario, this will work fine without any issues
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