Description
Winshuttle User Governance has been installed on an internal server. User can open the User Governance, LMS and Foundation sites from his local computer using port forwarding (localhost). When connecting to Studio using the site URL as Administrator, error appears: The Connect Service cannot be connected
Applies to
Foundation 11
Studio 11.2
LMS
Cause
1. Customer has a unique environment. He was using TCP port forwarding. According to design of foundation, it will never work. So he got a new machine and installed studio. Still we had to cross proxy of LMS and SharePoint. It was also throwing 417-expectations failed error. Added following snippet in <configuration> element of Winshuttle Studio.exe.config file
<system.net>
<defaultProxy>
<proxy
usesystemdefault="false"
/>
</defaultProxy>
<settings>
<servicePointManager expect100Continue="false" />
</settings>
</system.net>
2. User missing one of the "Assign" steps on the under User Governance > Manage Licenses
Solution
1. Add the following code in web.config file in the SAP IS Manager, if it is not already added, as this was found to solve the same error in previous cases:
<system.net>
<settings>
<servicePointManager expect100Continue="false" />
</settings>
</system.net>
2. Retest the connection
Further trouble shooting steps as below if above doesn't resolve the issue.
Check user is able to login to Foundation site both on local machine and on server.
Check Loupe and LMS services are running ; might as well restart.
Check their enough storage space available on the SQL DB
Restart the Server
Check the event logs
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