Description:
Email Approval is not working but the emails are getting into the dedicated email inbox.
Applies To:
Foundation/Workflow 11.x and 12.x
Cause:
One of two things:
1. The IMAP or POP3 port are not yet configured to function on the Mail Server.
This will need to be verified by your IT department or responsible Microsoft Exchange Mail server Admin.
2. One or more of the configuration keys in Workflow Central Administration is not setup correctly
Solution/Immediate Workaround:
If the Port is not configured to be open by the IT team, then that needs to be configured and the scenario tested again
OR
Check to see that all of the correct information is within each of the EMailApproval Configuration Keys
NOTE: Each key is VERY case sensitive. For example, IMAP does not work , but imap does. Please refer to the below link for specific details about each key.
How to configuring Email Approval Keys:
Login to the Winshuttle Workflow Administration site using the workflow Admin user
Note:
Before configuring the below keys in Workflow Administration (purple site) - make sure "Email Approval = TRUE" for all your "Approval" Nodes in the solution.
Keys to configure in WF Administration:
- Open the WF Administration screen - click on "Config Options" under Server Administration section
- Here, "Name = Copy and paste one of the keys from the below list"; "Display Keys = All available keys" - click on SEARCH
- Configure all the keys below and test your use case.
Keys:
EMailApprovalAddress - Full email address to send all Workflow assignment-related emails.
EMailApprovalUser - The name of the email account.
EMailApprovalPassword - The password for the account. This can either be clear text or encrypted.
EmailApprovalUserDomain - The email approval user domain for the server
EMailApprovalMailServer - The name of the email server.EMailApprovalMailServerPort – Server Port
EMailApprovalMailServerType – Server Type
EMailApprovalRescheduleTime – The time they want Workflow to check for email approval mails.It is in Minutes.
EMailApprovalUseSSL - Whether or not to use SSL when the email approval mailbox is polled
Additional Information:
Please see specific information about each key at this location:
http://winshuttle-help.s3.amazonaws.com/foundation/en/options.htm
Comments
0 comments
Please sign in to leave a comment.