Description:
Emails are not being sent out for Tasks generated by the Workflow Engine. General SharePoint emails may or may not also be failing
Applies To:
All versions of Workflow and SharePoint
Cause:
Primary:
The Outgoing Email settings on the SharePoint Web Application are not set
Secondary:
The Workflow Configuration key "SMTPHost" is not configured
Solution/Immediate Workaround:
To figure out the correct cause, go into SharePoint and try to add a user to a group. If the user receives the email notification, skip to step 6 below:
- Go to SharePoint Central Administration
- Go to Manage Web Applications
- Select the Web Application in question
- Go to General Settings > Outgoing Email
- Ensure that the fields are all filled out, then try the scenario again
- Go to Winshuttle Workflow Administration > Configure Options
- Change the "Display Keys" dropdown to All Available Keys
- Search for "smtphost" > Click on the result
- Click Add New Value
- Select Global for the Scope dropdown
- Type the name of your company SMTP server and press Add
- Press Save
- Perform an IIS Reset or wait 5-10 minutes for the key to take effect, then try the scenario again
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