Description
While upgrading the Winshuttle Workflow from 10.9.1 HF1 to Workflow 10.9.1 HF3, in some instances the upgrade fails and gives the error message saying: "Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding. The statement has been terminated"
Applies to
Workflow 10x and 11x
Cause
If some of the database queries (which are residing inside the installer folder, running against the existing SQL database tables) take long time to update the database due to heavy load on the SQL Server, then this SQL timeout issued stops the installer from upgrading.
Solution
-
In the Installer folder, navigate to
"Drive:\WSWorkflow\WinshuttleWorkflowInstaller_2013\Resources\Tools\Admin\Configuration Files"
-
Copy "RepairOrUpgrade.sql" file to SQL Server and paste on the desktop
-
Double click on
"RepairOrUpdate.sql"
file - which opens the file in SQLServer
-
click on
"Execute"
- It executes all the Queries against the Workflow database tables and generates the results
-
Look for any error/warning messages in the Report. If there are any warning/error messages in the report (which will tell the exact query name, line number in the report), then comment that particular query in the "RepairOrUpgrade.sql"
-
Save
the "RepairOrUpgrade.sql"
-
Run the Installer using
"Run as Administrator"
option
-
The Winshuttle workflow software will gets upgraded to latest version smoothly without any issues
-
Copy
the lines of Query, that you have commented in
step 5
-
Go to
SQL Server
and
Paste the Query
and click on
"Execute"
-
The query gets executed successfully, which will complete the Winshuttle Workflow Upgrade process.
Comments
0 comments
Please sign in to leave a comment.